티스토리 뷰
Day 2. 문제
Instructions
If the bill was $150.00, split between 5 people, with 12% tip.
Each person should pay (150.00 / 5) * 1.12 = 33.6
Format the result to 2 decimal places = 33.60
Thus everyone's share of the total bill is $30.00 plus a $3.60 tip.
Tip: There are 2 ways to round a number. You might have to do some Googling to solve this.💪
Example Input
Example Output
위 문제를 풀어야 하는데.....
print("Welcome to the tip calculator!")
bill = input("What was the total bill ?")
float(bill)
tip = input("How much tip would you like to give? 10, 12, or 15? ")
int(tip)
people = input("How may people to split the bill? ")
int(people)
total = ((bill / people ) * round(tip,2))
print(f"Each person should pay: ${total}")
내가 풀다 오류 나서 못 풀었다...
아 2일 차부터 헤딩하면 답 없는데...
힌트도 영어고.. 힘들다
Error
이거 에러 메시지도 복사가 안돼서 일일이 타이핑해야 할 판이다...
그냥 답을 볼가 하다가 에러를 검색해보기로 했다..
input 함수 앞에 int , float를 주어서 입력값 자체를 형 변환하고 변수에 넣으라는 거 봤다
근데.... 이거 수업 앞부분에서 했던 거 같다.... 역시 나는 돌대가리다...
바로 적용 후
에러는 해결 됐는데 결과 값이 개판이다...
소수점 뒤에 자를 아는데 그리고... 예제에서 124.56에 12% , 7명 하면 19.93 이 나와야 하는데
이거 뭔가 미친 거다... 산수.... 어렵다 산수.. 프로그래밍 2일 차에 이런 난제를.... 난 프로그램으로 성공은 못할 거다..
결국 23:47이라 더 이상 끌면 내일 출근도 힘들고 술기운도 올라와서 이제 그냥 정답을 봐버렸다
산수가 문제다 산수.... 아..... 곱하기 나누기도 못하는 42살이라니... 이거 프로그램 공부할게 아니라...
산수부터 공부해야겠다.
정답은
# Practice
print("Welcome to the tip calculator!")
bill = float(input("What was the total bill? $"))
tip = int(input("How much tip would you like to give? 10, 12, or 15? "))
people = int(input("How may people to split the bill? "))
tip_as_percent = tip / 100
total_tip_amount = bill * tip_as_percent
total_bill = bill + total_tip_amount
bill_per_person = total_bill / people
total = round(bill_per_person,2)
print(f"Each person should pay: ${total}")
round 함수 말고도 다른 방식이 있다
8월3일 4분전 ... 내일 지각 하지 않기 위해서 오늘은 여기 까지.. 아... 영어 공부 못했내..
술을 끊던가 해야지 진짜...
술 끊자!
'Programming > Python' 카테고리의 다른 글
파이썬 기초 공부 - Hangman (행맨) (0) | 2022.12.21 |
---|---|
Day 5. For , List , Random(Mathod/choice,shuffle) (0) | 2022.08.29 |
Day 4. Random , List , Sequence (0) | 2022.08.16 |
Day 3 . if / else (0) | 2022.08.05 |
Day 1. 변수 와 문자 입력 받기(print , input) (0) | 2022.08.01 |
- Total
- Today
- Yesterday
- grootsecuriry
- CTF
- 쉘 스크립트 기초
- 리눅스 환경변수 지정
- Rcity1번
- rhcsa8 기출문제
- rhcsa8 시험문제
- 리눅스 쉘 스크립트
- rhcsa8덤프
- 리눅스 명령어
- RCity operation 1
- Rcityboan.com
- 파이썬기초
- 파이썬실습
- gzip
- podman
- 리눅스본딩
- 주소DB만들기
- grootboan
- rhcsa8
- 라쿤시티
- Rcity CTF
- Rcity
- 맨탈훈련
- rhcsa8 덤프
- 7-zip
- 리눅스
- Grootsecurity
- PODman기초
- Rcity 9번
일 | 월 | 화 | 수 | 목 | 금 | 토 |
---|---|---|---|---|---|---|
1 | 2 | 3 | 4 | 5 | ||
6 | 7 | 8 | 9 | 10 | 11 | 12 |
13 | 14 | 15 | 16 | 17 | 18 | 19 |
20 | 21 | 22 | 23 | 24 | 25 | 26 |
27 | 28 | 29 | 30 |